CMS Made Simple 1.7.1 "Escade" veröffentlicht

CMSMS wird besser und besser ...

Obwohl diese Version nur eine kleine Änderung in der Versionsnummer hat, enthält sie zahlreiche Fehlerkorrekturen und einige wichtige neue Funktionen. Wir wollten sie nicht mit Versionsnummer 1.8 veröffentlichen, weil die Änderungen nicht so gravierend waren, obwohl wir versucht haben, möglichst viele Dinge mit einzuarbeiten. Das heißt, wir haben die Änderungen eingearbeitet, die einfach zu implementieren waren und wenig Einfluss auf bereits existierende Seiten haben, aber viele Dinge für die Anwender einfacher machen. Wir denken aber, dass die Änderungen wichtig genug sind, um schnellstmöglich zu aktualisieren.

Eine der größten Änderungen ist die bessere Unterstützung von SSL. Es gibt nun einen (zusätzlichen) ssl_url Parameter in der config.php und ein Kontrollfeld in der Registerkarte "Optionen" beim Bearbeiten von Seiten, um HTTPS für jede einzelne Seite zu (de)aktivieren. Diese Funktion wurde schon lange gewünscht.

Wir haben die Modul-API geändert, so dass nun jedem Formular-Element, das von einem Modul erzeugt wird (Formular-Tag, Texteingabefeld, Kontrollfeld etc.), eine CSS-Klasse zugeordnet wird. Dies macht es Designern viel einfacher, die Formulare zu gestalten.

Neu ist auch Einstellungmöglichkeit für die Größe der Vorschaubilder in der Bildverwaltung (anstatt eine Konfigurationsdatei zu bearbeiten). Es gibt auch eine neue Benutzer-Einstellung, um eine Blätterfunktion für Globale Inhaltsblöcke, Stylesheet- und Template-Listen zu aktivieren. Außerdem gab es ein paar kleinere Änderungen und Fehlerkorrekturen an den Core-Modulen, um ein paar Probleme zu beheben und uns das Leben etwas einfacher zu machen. TinyMCE wurde wieder auf die neueste Version aktualisiert (hoffentlich gibt es diesmal weniger Probleme beim Aktualisieren).

Diesmal gibt es eine Änderung des Datenbank-Schemas, um die SSL-Änderungen einzuarbeiten, weshalb es auch keine Diff-Dateien gibt. Daher ist für jeden eine Aktualisierung über den Start von /install/upgrade.php zwingend erforderlich.

Wir wollen auch diesmal wieder den Anwendern danken, die unzählige Stunden investiert haben, um diese Version zu testen, Fehler zu beseitigen, zu übersetzen und zu unterstützen. Spezieller Dank geht an:

  • Ronny Krijt (ronnyk)
  • Nuno Costa (nuno)
  • Rene Helminsen (reneh)
  • Jeremy Bass (JeremyBass)
  • Tyler Boespflug (tyman00)
  • Mark Reed (DrCss)

Viel Spaß damit!

Version 1.7.1 - Escada

Folgende Fehler wurden beseitigt:

  • #3794 Benutzung von readfile() entfernt
  • #3854 Problem beim Suchen von mehreren Wörtern
  • #3901 Formulare benutzten SERVER_NAME und nicht HTTP_HOST, das verursachte Konflikte mit Canonical Redirects
  • #4009 Module konnten nicht aktualisiert werden oder funktionierten nicht bei der Benutzung von SSL
  • #4138 Der Interne Seitenlink (Inhaltstyp) funktionierte unter bestimmten Bedingungennicht
  • #4032 Formulare in der Administration funktionierten nicht mit HTTPS
  • #4209 Das Alias-Feld wurde beim Inhaltstyp "Abschnittsüberschrift" nicht angezeigt
  • #4321 Der Parameter cms_module action wurde mit "mact" überschrieben
  • #4414 Die voreingestellte (Start-)Seite wurde manchmal auf inaktiv gesetzt
  • #4500 Das Zugriffsrecht "Remove Global Content Block" (Globale Inhaltsblöcke entfernen) funktionierte nicht
  • #4507 Indexe wurden nicht mit dem Datenbank-Prefix erzeugt
  • #4551 Objektorientierte Programmierung
  • #4603 ContentStylesheet wurde nicht getriggert
  • #4720 Fehler in der Datei class.module.inc.php
  • #4779 Die Aktualisierungs-Seite zeigt fehlerhafte Informationen
  • #4838 htmlentities in current_date
  • Fehlender Tag im Template accessible_simple_navigation.tpl
  • für eine einfachere Gestaltung wird nun jedem Formular-Element eine CSS-Klasse zugeordnet
  • Benutzerdefinierte Einstellung für Blätterfunktion in Globalen Inhaltsblöcken, Stylesheet- und Template-Listen hinzugefügt
  • Seiteneinstellungen für die Breite und Höhe von Vorschaubildern hinzugefügt (wird primär von der Bildverwaltung verwendet, kann aber auch von anderen Modulen benutzt werden
  • kleineres Sicherheitsproblems in den Benutzer-Einstellungen behoben

News:

  • #4304 Logik-Problem beim Ablaufdatum
  • #4659 Dokumentations-Fehler
  • #4550 Eine neue Sortiermöglichkeit hinzugefügt

Menu Manager:

  • Verbesserungen bei der Anzeige der Template-Liste

TinyMCE

  • #4769 TinyMCE verursacht Probleme bei komischen Ã?berschriften einer Seite
  • Aktualisierung auf TinyMCE 3.3.3
  • Einstellmöglichkeit hinzugefügt, um Modulen zu erlauben, Funktionalitäten für den Editor zu erstellen
  • Möglichkeit, den die Größe des Editors live zu ändern

Zurück

Impressum  ·  Datenschutz  ·  Kontakt  ·  Spenden  ·  Inhaltsverzeichnis

© Copyright 2006-2021 by Andreas Just